upgrade van Seamonkey 1.19 naar 2.0x

Mozilla Suite is de huidige Mozilla met alles erop en eraan, dus inclusief MailNews, Composer, etc. De ontwikkeling van Mozilla Suite wordt op den duur stopgezet en vandaar dat het project SeaMonkey is gestart. Qua mogelijkheden en functies komt het sterk overeen met Mozilla Suite.
wim1231
Berichten: 3
Lid geworden op: 10 Augustus 2010, 17:00
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.8.1.24) Gecko/20100228 SeaMonkey/1.1.19

upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor wim1231 » 10 Augustus 2010, 17:43

Wie kan mij helpen / raad geven?
Ik gebruik al een jaar of twee Seamonkey als browser en mail pakket, en dat tot tevredenheid. Regelmatig geupdate tot versie 1.19. Ook wij overgang naar Windows 7 verliep goed.
Ik heb vanaf versie 2.0 geprobeerd deze te installeren, maar dat lukt van geen kant. Tot nu toe niet zo'n probleem, maar sinds de laatste Java update werkt Java niet meer samen met SeaMonkey 1.X, dus ik zal wel moeten.
Als ik een 2.x versie heb geinstalleerd krijg ik telkens een (engelstalige) foutmelding dat er al een andere versie van Seamonkey aktief is, dat ik deze moet afsluiten en het dan opnieuw moet proberen. Ik heb via het configuratie scherm (geprobeerd) om Seamonkey te verwijderen, en daarna 2.x te installeren. Dat lijkt te lukken, maar Seamonkey geeft nog steeds dezelfde foutmelding. Ik heb op de site van Seamonkey een handleiding gevonden waarin stond dat er bepaalde directories verwijderd moesten worden (de GRE folder en de Mozilla.org folder), maar ook dat helpt niet.

Wie weet raad?

Bij voorbaat dank

Wim

Gebruikersavatar
Pettic
Berichten: 3352
Lid geworden op: 28 November 2004, 11:45
Locatie: Rotterdam
Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.2.8) Gecko/20100722 Ant.com Toolbar 2.0.1 Firefox/3.6.8

Re: upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor Pettic » 10 Augustus 2010, 20:09

Probeer eerst Seamonkey te de-installeren. Daarna de map Seamonkey uit \Program Files\ geheel verwijderen.
Eventueel Ccleaner erop loslaten. Nieuwe versie downloaden en installeren.
Windows (64); Firefox; Thunderbird

Gebruikersavatar
Tonnes
Berichten: 814
Lid geworden op: 20 November 2004, 21:40
Mozilla/5.0 (Windows; U; Windows NT 5.0; nl-NL; rv:1.8.1.24) Gecko/20100228 SeaMonkey/1.1.19

Re: upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor Tonnes » 10 Augustus 2010, 20:41

Heb je toevallig de Quick Launch-optie ingesteld? In de NL-versie vind je dit onder Bewerken - Voorkeuren - Geavanceerd - (vakje) Snel starten. In dat geval wordt SeaMonkey niet volledig afgesloten nadat het is gebruikt, of is het mogelijk al na starten van Windows actief. :?:
Doe eens gek. Let op je spelling.

Gebruikersavatar
Pettic
Berichten: 3352
Lid geworden op: 28 November 2004, 11:45
Locatie: Rotterdam
Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.2.8) Gecko/20100722 Ant.com Toolbar 2.0.1 Firefox/3.6.8

Re: upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor Pettic » 11 Augustus 2010, 21:33

Goeie opmerking Tonnes! Dat herinner ik me nog van mijn Mozilla Suite tijdperk voordat ik op Firefox overstapte.
Windows (64); Firefox; Thunderbird

wim1231
Berichten: 3
Lid geworden op: 10 Augustus 2010, 17:00
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.8.1.24) Gecko/20100228 SeaMonkey/1.1.19

Re: upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor wim1231 » 12 Augustus 2010, 18:12

Allemaal,

Dank voor de reacties, maar Seamonkey start niet automatisch op (gecontroleerd met Norton en in programmanager).

Is er nog iemand anders die een goede suggestie heeft?

Bij voorbaat dank,

Wim

Gebruikersavatar
nirwana
Beheerder
Berichten: 11229
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Re: upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor nirwana » 12 Augustus 2010, 22:35

Wim,

Kun je die Engelstalige melding ook hier op het forum plaatsen ?
Mogelijk helpt dat ons om een idee te vormen wat er aan de hand kan zijn.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

wim1231
Berichten: 3
Lid geworden op: 10 Augustus 2010, 17:00
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.8.1.24) Gecko/20100228 SeaMonkey/1.1.19

Re: upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor wim1231 » 13 Augustus 2010, 20:50

Nirwana,

de foutmelding luidt:

SeaMonkey is already running, but is not responding. To open a new window, you must first close the existing SeaMonkey process, or restart your system.

Ik hoor dat jullie een idee hebben.

Groet,

Wim

Gebruikersavatar
Tonnes
Berichten: 814
Lid geworden op: 20 November 2004, 21:40
Mozilla/5.0 (Windows; U; Windows NT 5.0; nl; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Re: upgrade van Seamonkey 1.19 naar 2.0x

Berichtdoor Tonnes » 14 Augustus 2010, 8:37

Voor de duidelijkheid (maar ik kan je verkeerd begrepen hebben): het gaat er niet om dat SM automatisch opstart met Windows via een opstartgroep o.i.d., maar dat de Quick Launch-optie niet actief mag zijn, omdat deze ervoor zorgt dat een deel van het programma op de achtergrond geladen blijft als het wordt afgesloten, en SM zelfs na het starten van Windows al via de registry wordt geactiveerd. Je zou dan echter een pictogram in de rechteronderhoek én het proces seamonkey.exe in de taakbeheerder moeten zien, en dat lijkt er niet op. Bovendien treedt je probleem op bij SM 2.0.x, die deze “turbo-optie” niet meer heeft. Ik weet overigens niet wat Norton hierin kan betekenen, maar dat terzijde.

Omdat de foutmelding de standaardtekst van de profielbeheerder voor Mozilla-producten is en een groot deel van de broncode met Firefox wordt gedeeld, heb je wellicht wat aan het bijbehorende ondersteuningsartikel voor hetzelfde verschijnsel in Firefox. Vermoedelijk is er een vergrendelingsbestand aanwezig in je profiel, of kan het profiel niet worden gevonden, mogelijk omdat het inmiddels is verwijderd. De profielformaten van versie 1.1.x en 2.0 zijn meen ik hetzelfde, dus daarop zou het niet fout mogen gaan (in het geval dat 2.0 dat van 1.1x wil gebruiken).

1) Bestaat er een bestand parent.lock in de profielmap van 2.0 wanneer SM niet actief is? De profielmap vind je in jouw geval het snelst door %APPDATA% in het dialoogvenster Uitvoeren via het menu Starten te typen, gevolgd door Enter. Profielen voor 1.1 bevinden zich doorgaans in Application Data\mozilla.org\Profiles\SeaMonkey, dat van 2.0 in Application Data\Mozilla\SeaMonkey\Profiles, wat op zich een teken is dat er geen gedeeld profiel is, tenzij je bewust dezelfde profielmap voor beide versies hebt gekozen. Eenvoudig gezegd: verwijder alle parent.lock-bestanden die je kunt vinden als er geen enkele versie van SeaMonkey actief is; mogelijk bestaat zo’n bestand in het huidige 2.0-profiel. Controleer ook of het bestand profiles.ini in de laatstgenoemde map een mapnaam bevat die overeenkomt met de werkelijke map die door het profiel wordt gebruikt. Je kunt dus iets zien als Path=Profiles/abc12de3.default, wat inhoudt dat de map abc12de3.default op zijn minst aanwezig moet zijn.

2) Wat gebeurt er als je SeaMonkey start met de optie -p ? De eenvoudigste manier hiervoor is -p toevoegen aan de bestaande snelkoppeling (voor 2.0 dus). Een andere manier is een command prompt openen in de programmap van SM (meestal C:\Program Files\SeaMonkey) en dan seamonkey -p intypen. Je zou dan i.i.g. de profielbeheerder moeten zien en, nu je er toch bent, een nieuw (test)profiel kunnen maken. Als de profielbeheerder al niet verschijnt en de foutmelding wel, zou pas écht sprake zijn van een reeds actief Firefox-proces, wat meestal duidt op een stukje malware dat zichzelf de naam seamonkey.exe geeft en wellicht ook niet in Taakbeheer verschijnt, maar die kans is klein, ook omdat 1.1.x wel werkt.

Zie ook Profile in use en Profile folder bij de kb van mozillaZine.
Doe eens gek. Let op je spelling.


Terug naar “Mozilla Suite/SeaMonkey”