Zoomtext 10.1

Mozilla Firefox is de webbrowser van Mozilla. Volg in geval van problemen eerst onze standaard diagnose.
MvS
Berichten: 6
Lid geworden op: 26 Oktober 2016, 22:17
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Zoomtext 10.1

Berichtdoor MvS » 16 November 2016, 12:32

Beste Forumleden.
Ik gebruik vanwege slechtziendheid de schermvergrotings software van Zoomtext van Ai Squared in windows10 64x.
Sinds de update van Firefox 48.02 naar 49 en 50 heb ik problemen met de leesbaarheid van de tekst, letters zijn rafelig en bestaan voornamelijk uit puntjes.
Dit werd normaal gecompenseerd door Zoomtext door de letters glad te maken (xFont) en tot versie 48 was dit geen probleem.
In Firefox 49 en 50 is het een en ander veranderd, dit heb ik in eerdere versies wel eens kunnen verhelpen door in about:config de instelling : layers, offmainenthread om te schakelen.
Deze instelling blijkt in de nieuwe versie niet meer aanwezig te zijn.
Mijn vraag is dus, is het mogelijk om de xFont in versie 50 aan te passen zodat de tekst weer leesbaar wordt bij gebruik van Zoomtext ?

En ja ik heb uitputtend e-mail contact gehad met Ai Squared, maar die stellen dat de problemen veroorzaakt worden door updates van Firefox.
En ja ik kan downgraden naar Firefox 48.02, ik hoef hier niemand te wijzen op het belang van een veilige webbrowser ?

Inmiddels is Zoomtex ge-updated maar dit heeft alleen effect op de tekst in de werkbalken en niet op de tekst in de websites.
Wel zijn gek genoeg de afbeeldingen op de websites scherp te zien.

Kunnen de Wizzkids op dit forum mij helpen aan een bruikbare oplossing ?
Ik zou heel erg dankbaar zijn !!!
Martien.

Torzan
Berichten: 470
Lid geworden op: 16 Januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: Zoomtext 10.1

Berichtdoor Torzan » 16 November 2016, 20:04

Welke instelling (pref) bedoel je precies? Ik kan niets vinden over het niet meer ondersteunen van de genoemde, en er zijn er wel een paar die erop lijken. Overigens zou je de instelling alsnog kunnen toevoegen (rechtermuisknop > Nieuw, Boolean).

Staan de instellingen voor Kleuren in Opties > Inhoud > Kleuren… goed, d.w.z. zodat 'Systeemkleuren gebruiken' niet is geselecteerd, en eronder óf 'Nooit', óf 'Alleen bij thema's met hoog contrast' is geselecteerd? Mogelijk heb je de laatste optie geselecteerd en ook een thema met hoog contrast ingesteld en is deze voor jou ook nodig, dan wordt het even verder zoeken, maar probeer het eerst eens met 'Nooit'.

Het geschikt maken van externe software, of het nu virusscanners, andere beveiligingsproducten of schermlezersoftware betreft, is een taak van de makers ervan, en in de regel niet van Firefox, zeker als er echt sprake is van een functie die niet meer wordt ondersteund.

MvS
Berichten: 6
Lid geworden op: 26 Oktober 2016, 22:17
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Re: Zoomtext 10.1

Berichtdoor MvS » 17 November 2016, 10:55

Torzan,
Bedankt voor uw aanbevelingen.
Ik heb de Kleureninstellingen in Opties nagelopen, en diverse combinaties uitputtend uitgeprobeerd maar de letters worden niet beter zichtbaar.
Met uw opmerking over "het geschikt maken van externe sofware" ben ik het wel eens maar het vervelende is dat ik tot versie 48 geen last had van onduidelijke letters, en Zoomtext al meer dan 8 jaar compatible was met Firefox.
Ik zal nog eens wat opties nalopen in about:config.
Anders is voor mij de Firefox browser na 8 jaar gebruik een gepasseerd station.
Groet MvS.

Torzan
Berichten: 470
Lid geworden op: 16 Januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: Zoomtext 10.1

Berichtdoor Torzan » 17 November 2016, 20:39

Toch is het een zaak van Zoomtext om de boel bij te houden of aan te passen als de 'core' van Firefox of welke browser dan ook wordt gewijzigd. De frustratie begrijp ik ook wel, maar het gaat nu om de oplossing. Kun je de exacte naam van de voorkeursinstelling geven die uit versie 49 zou zijn verwijderd? Als het een kwestie van multi-process is, zou je browser.tabs.remote.autostart op false kunnen zetten. En heb je hardwareversnelling geprobeerd uit te schakelen? Zie ook deze supportvraag.

MvS
Berichten: 6
Lid geworden op: 26 Oktober 2016, 22:17
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Re: Zoomtext 10.1

Berichtdoor MvS » 18 November 2016, 10:36

De voorkeursinstelling die ik bedoelde had ik gevonden in een post van Tweakers.net over een Firefox update, ik meen 38 of39.
Een gebruiker meldde toen een zelfde probleem met de xfont , rafelige letters e.d. ik kreeg toen ook dat probleem.
Er werd toen aangeraden om in about:config de pref. Layers.offmainthread.composition. enabled om te zetten.
ik heb dat toen ook gedaan, en de mooie leesbare gladde letter was weer terug, ik kan het bewuste bericht in Tweakers niet meer terugvinden, maar heb toen deze oplossing genoteerd .
Sindsdien heb ik steeds Firefox vanuit de browser ge-updated waardoor steeds de instellingen vanuit de vorige versie werden overgenomen.
Vreemd genoeg is deze mogelijkheid om deze pref om te schakelen nog steeds in Thunderbird 45.4 x86 aanwezig, terwijl in Firefox dit niet meer zichtbaar is.
ik heb browser.tabs.remote.autostart op false gezet, maar zonder zichtbaar resultaat.

De hardware versnelling staat bij mij standaard uit.
Zoomtext geeft zelfs een waarschuwings pop-up mocht deze ingeschakeld zijn.
Ai Squared gaf gisteravond via de mail aan dat ze gaan bekijken of dit probleem via een update op te lossen is.
maar:herhaalde dat het probleem door een update van Firefox veroozaakt wordt ! pffff. en raadt aan voorlopig terug te gaan naar versie 48.

Ik heb nu versie 48.02 ge-download maar Eset geeft vaak aan dat certificaten onveilig of verlopen zijn, dus vanwege internetbankieren , betalingen in webshops, geeft me dit geen veilig gevoel
MvS

Torzan
Berichten: 470
Lid geworden op: 16 Januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: Zoomtext 10.1

Berichtdoor Torzan » 18 November 2016, 13:56

Bedankt, zo kunnen we iets. :) Volgens dit bericht op Tweakers zou het om layers.offmainthreadcomposition.enabled kunnen gaan, die door bug 1259466 is hernoemd, waarschijnlijk in versie 48. Kun je eens een nieuwe (Boolean) waarde toevoegen met de naam layers.offmainthreadcomposition.force-disabled en de waarde true?

MvS
Berichten: 6
Lid geworden op: 26 Oktober 2016, 22:17
Mozilla/5.0 (Android 7.1.1; Mobile; rv:49.0) Gecko/49.0 Firefox/49.0

Re: Zoomtext 10.1

Berichtdoor MvS » 18 November 2016, 17:26

Torzan,
Ik heb in about:config de nieuwe waarden toegevoegd, en de tekst is voor mij met 8x vergroting in Zoomtext 10 weer goed leesbaar.
Het vreemde is dat nu de letters in websites zoals Tweakers goed en mooi glad afgerond worden weergegeven maar in de uitval menus rafelig blijven.
Als ik tekst in het zoekveld invoer, dan zijn die ook mooi glad terwijl de lijnen van het zoekveld rafelig blijven.

Maar als dit het beroemde compromis is, dan ben ik er zeer tevreden over, en kan in ieder geval weer het internet op middels een veilige browser.
Heel erg bedankt voor uw ondersteuning.
Martien aka MvS

Torzan
Berichten: 470
Lid geworden op: 16 Januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: Zoomtext 10.1

Berichtdoor Torzan » 18 November 2016, 21:31

Graag gedaan, blij dat het werkt. Aangezien je contact hebt gehad met de maker van ZoomText, is het misschien een idee om deze info door te geven? Dit is de link die hem verder kan helpen. Hij heeft overigens wel een punt door te zeggen dat de oorzaak bij Firefox ligt, maar nogmaals, omwille van vooruitgang en goed onderbouwde codewijzigingen zou hij moeten volgen, net als alle andere add-ons. Als autoradio's met formaten die jarenlang in oudere dashboards pasten dat ineens niet meer doen doordat alles 'inbouw' wordt, zullen de makers ervan ook mee moeten gaan. ;)

Met specifieke lettertypen en verschillen bij bv. Tweakers kan ik je niet helpen, maar misschien dat anderen met een grotere voorliefde voor HTML e.d. alhier dat wel kunnen? Mogelijk gaat het om 1 bepaald lettertype (iets met TrueType en extern?) dat je moet downloaden. Tenzij je zeker weet dat dit er nu anders uitziet dan voor versie 48, en bij gebruik van hetzelfde Firefox- of Windows-thema…

MvS
Berichten: 6
Lid geworden op: 26 Oktober 2016, 22:17
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Re: Zoomtext 10.1

Berichtdoor MvS » 21 November 2016, 12:26

Ik heb de link omtrent layers.offmainthreadcomposition.enabled in een e-mail bericht naar Ai Squared gestuurd.
Ondersteuningsoftware zoals Zoomtext lopen per definitie achter ontwikkelaars als Mozilla aan.
Via Optelec.nl (de retailer in nederland) heb ik begrepen dat in een volgende update een fix zou komen voor het html probleem.
Voorlopig is het een werkbare situatie, anders dan in IE11 waar sites zoals Marktplaats steeds vastlopen, ik vermoed door Adblock.
Tot zover, groet MvS.

MvS
Berichten: 6
Lid geworden op: 26 Oktober 2016, 22:17
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Re: Zoomtext 10.1

Berichtdoor MvS » 30 December 2016, 11:17

Image of Bug FixxFont magnification now supported in Firefox 49
ZoomText’s xFont magnification is now provided in in the Firefox 49 web browser.

Eindelijk, nu zijn de uitvalmenu's ook weer goed leesbaar!
Alvast iedere bezoeker van dit Forum een voorspoedig 2017 gewenst.
MvS

Gebruikersavatar
nirwana
Beheerder
Berichten: 11139
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Re: Zoomtext 10.1

Berichtdoor nirwana » 30 December 2016, 23:17

Beste Martien,

Bedankt dat je dit hier met ons deelt.

Jij natuurlijk ook alvast de beste wensen voor 2017.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]


Terug naar “Mozilla Firefox”